import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/demo.happy-visitor.com\\/";
final String string = "http://www.website.com\n"
+ "https://www.website.com\n"
+ "www.website.com\n"
+ "website.com\n"
+ "http://website.com\n"
+ "https://website.com\n"
+ "fb.com\n"
+ "https://demo.happy-visitor.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}