$re = '/https:\/\/demo.happy-visitor.com\//i';
$str = 'http://www.website.com
https://www.website.com
www.website.com
website.com
http://website.com
https://website.com
fb.com
https://demo.happy-visitor.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);