package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https:\/\/demo.happy-visitor.com\/`)
var str = `http://www.website.com
https://www.website.com
www.website.com
website.com
http://website.com
https://website.com
fb.com
https://demo.happy-visitor.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}