re = /https:\/\/demo.happy-visitor.com\//i
str = 'http://www.website.com
https://www.website.com
www.website.com
website.com
http://website.com
https://website.com
fb.com
https://demo.happy-visitor.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end