using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/demo.happy-visitor.com\/";
string input = @"http://www.website.com
https://www.website.com
www.website.com
website.com
http://website.com
https://website.com
fb.com
https://demo.happy-visitor.com/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}