#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([?&])\s*&"
Local $sString = "test1?&test2" & @CRLF & _
"test2&&test2" & @CRLF & _
"test3? &test2" & @CRLF & _
"test4? &test2" & @CRLF & _
"test5& &test2" & @CRLF & _
"test1& &test2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")