using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([?&])\s*&";
string input = @"test1?&test2
test2&&test2
test3? &test2
test4? &test2
test5& &test2
test1& &test2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}