re = /([?&])\s*&/
str = 'test1?&test2
test2&&test2
test3? &test2
test4? &test2
test5& &test2
test1& &test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end