import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([?&])\\s*&";
final String string = "test1?&test2\n"
+ "test2&&test2\n"
+ "test3? &test2\n"
+ "test4? &test2\n"
+ "test5& &test2\n"
+ "test1& &test2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}