$re = '/([?&])\s*&/';
$str = 'test1?&test2
test2&&test2
test3? &test2
test4? &test2
test5& &test2
test1& &test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);