#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\s])http:"
Local $sString = "http://dummyurl1http://dummyurl2 http://dummyurl3" & @CRLF & _
""
Local $sSubst = "$1 http"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)