$re = '/([^\s])http:/';
$str = 'http://dummyurl1http://dummyurl2 http://dummyurl3
';
$subst = "$1 http";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;