using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s])http:";
string substitution = @"$1 http";
string input = @"http://dummyurl1http://dummyurl2 http://dummyurl3
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}