// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\s])http:").unwrap();
let string = "http://dummyurl1http://dummyurl2 http://dummyurl3
";
let substitution = "$1 http";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}