const regex = /([^\s])http:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s])http:', 'g')
const str = `http://dummyurl1http://dummyurl2 http://dummyurl3
`;
const subst = `$1 http`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);