import re
regex = re.compile(r"([^\s])http:")
test_str = ("http://dummyurl1http://dummyurl2 http://dummyurl3\n")
subst = "$1 http"
result = regex.sub(subst, test_str)
if result:
print(result)