using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$";
string substitution = @"";
string input = @"https://google.com:4201";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}