$re = '/([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$/';
$str = 'https://google.com:4201';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;