// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$").unwrap();
let string = "https://google.com:4201";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}