import Foundation
let pattern = #"([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://google.com:4201"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}