re = /([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$/
str = 'https://google.com:4201'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result