const regex = /([a-z+]+:\/\/)+([a-z]+)+(.com)+(:4201)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z+]+:\\\/\\\/)+([a-z]+)+(.com)+(:4201)$', '')
const str = `https://google.com:4201`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);