using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[-A-Z0-9+&@#\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\/%=~_|$]|""(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^""\r\n]+""|""(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^""\r\n]+""|'(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^'\r\n]+'";
string input = @"Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}