import Foundation
let pattern = ##"\b(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[-A-Z0-9+&@#\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\/%=~_|$]|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|'(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^'\r\n]+'"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}