const regex = /\b(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[-A-Z0-9+&@#\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\/%=~_|$]|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^"\r\n]+"|'(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^'\r\n]+'/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:https?|ftp|file):\\\/\\\/|(www|ftp)\\.)[-A-Z0-9+&@#\\\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\\\/%=~_|$]|"(?:(?:https?|ftp|file):\\\/\\\/|(www|ftp)\\.)[^"\\r\\n]+"|"(?:(?:https?|ftp|file):\\\/\\\/|(www|ftp)\\.)[^"\\r\\n]+"|\'(?:(?:https?|ftp|file):\\\/\\\/|(www|ftp)\\.)[^\'\\r\\n]+\'', 'is')
const str = `Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}