import re
regex = re.compile(r"\b(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[-A-Z0-9+&@#\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\/%=~_|$]|\"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^\"\r\n]+\"|\"(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^\"\r\n]+\"|'(?:(?:https?|ftp|file):\/\/|(www|ftp)\.)[^'\r\n]+'", flags=re.IGNORECASE | re.DOTALL)
test_str = "Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")