import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:https?|ftp|file):\\/\\/|(www|ftp)\\.)[-A-Z0-9+&@#\\/%?=~_|$!:,.;]*[-A-Z0-9+&@#\\/%=~_|$]|\"(?:(?:https?|ftp|file):\\/\\/|(www|ftp)\\.)[^\"\\r\\n]+\"|\"(?:(?:https?|ftp|file):\\/\\/|(www|ftp)\\.)[^\"\\r\\n]+\"|'(?:(?:https?|ftp|file):\\/\\/|(www|ftp)\\.)[^'\\r\\n]+'";
final String string = "Gitanas en los Jardines de Damasco 1963 RT “@aj_rromale: Photo: http://t.co/0G3jhTF5”";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}