#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:\bIN(?:\s*,)?)?" & @CRLF & _
"(?:\bVOL.?(?:U[NM]TARY)?)?(?:\s*,)? \b(?:LIQ'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\b"
Local $sString = "IN VOLUNTARY LIQUIDATION" & @CRLF & _
"IN VOL LIQ" & @CRLF & _
"IN VOL.LIQ" & @CRLF & _
"IN LIQUIDATION" & @CRLF & _
"IN LIQ" & @CRLF & _
"VOL LIQ" & @CRLF & _
"VOL.LIQ" & @CRLF & _
"VOL. LIQ" & @CRLF & _
"IN LIQ" & @CRLF & _
"IN VOL LIQUIDATION" & @CRLF & _
"IN LIQUIDATION" & @CRLF & _
"IN LIQ" & @CRLF & _
"IN, VOL. LIQ" & @CRLF & _
"IN VOLUMTARY, LIQN" & @CRLF & _
"LIQUIDATION" & @CRLF & _
"RECEIVERSHIP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")