import Foundation
let pattern = #"""
(?:\bIN(?:\s*,)?)?
(?:\bVOL.?(?:U[NM]TARY)?)?(?:\s*,)? \b(?:LIQ'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\b
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
IN VOLUNTARY LIQUIDATION
IN VOL LIQ
IN VOL.LIQ
IN LIQUIDATION
IN LIQ
VOL LIQ
VOL.LIQ
VOL. LIQ
IN LIQ
IN VOL LIQUIDATION
IN LIQUIDATION
IN LIQ
IN, VOL. LIQ
IN VOLUMTARY, LIQN
LIQUIDATION
RECEIVERSHIP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)