# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:\bIN(?:\s*,)?)?
(?:\bVOL.?(?:U[NM]TARY)?)?(?:\s*,)? \b(?:LIQ'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\b
"""
test_str = ("IN VOLUNTARY LIQUIDATION\n"
"IN VOL LIQ\n"
"IN VOL.LIQ\n"
"IN LIQUIDATION\n"
"IN LIQ\n"
"VOL LIQ\n"
"VOL.LIQ\n"
"VOL. LIQ\n"
"IN LIQ\n"
"IN VOL LIQUIDATION\n"
"IN LIQUIDATION\n"
"IN LIQ\n"
"IN, VOL. LIQ\n"
"IN VOLUMTARY, LIQN\n"
"LIQUIDATION\n"
"RECEIVERSHIP")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.