import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bIN(?:\\s*,)?)?\n"
+ "(?:\\bVOL.?(?:U[NM]TARY)?)?(?:\\s*,)? \\b(?:LIQ'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\\b";
final String string = "IN VOLUNTARY LIQUIDATION\n"
+ "IN VOL LIQ\n"
+ "IN VOL.LIQ\n"
+ "IN LIQUIDATION\n"
+ "IN LIQ\n"
+ "VOL LIQ\n"
+ "VOL.LIQ\n"
+ "VOL. LIQ\n"
+ "IN LIQ\n"
+ "IN VOL LIQUIDATION\n"
+ "IN LIQUIDATION\n"
+ "IN LIQ\n"
+ "IN, VOL. LIQ\n"
+ "IN VOLUMTARY, LIQN\n"
+ "LIQUIDATION\n"
+ "RECEIVERSHIP";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}