$re = '/(?:\bIN(?:\s*,)?)?
(?:\bVOL.?(?:U[NM]TARY)?)?(?:\s*,)? \b(?:LIQ\'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\b/x';
$str = 'IN VOLUNTARY LIQUIDATION
IN VOL LIQ
IN VOL.LIQ
IN LIQUIDATION
IN LIQ
VOL LIQ
VOL.LIQ
VOL. LIQ
IN LIQ
IN VOL LIQUIDATION
IN LIQUIDATION
IN LIQ
IN, VOL. LIQ
IN VOLUMTARY, LIQN
LIQUIDATION
RECEIVERSHIP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);