const regex = /(?:\bIN(?:\s*,)?)?
(?:\bVOL.?(?:U[NM]TARY)?)?(?:\s*,)? \b(?:LIQ'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bIN(?:\\s*,)?)?
(?:\\bVOL.?(?:U[NM]TARY)?)?(?:\\s*,)? \\b(?:LIQ\'N|LIQ|LQD|LIQD|LIQN|LIQUIDA|LIQUIDATION|REC|RECEIVERSHIP|RECSHIP|WINDING UP)\\b', 'g')
const str = `IN VOLUNTARY LIQUIDATION
IN VOL LIQ
IN VOL.LIQ
IN LIQUIDATION
IN LIQ
VOL LIQ
VOL.LIQ
VOL. LIQ
IN LIQ
IN VOL LIQUIDATION
IN LIQUIDATION
IN LIQ
IN, VOL. LIQ
IN VOLUMTARY, LIQN
LIQUIDATION
RECEIVERSHIP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}