#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<string>"[^"]+")" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"\(" & @CRLF & _
" (?&string)?" & @CRLF & _
" (?:,(?&string)?)*" & @CRLF & _
"\)"
Local $sString = "("My","Cool","Array")" & @CRLF & _
"("My","Cool","Array",)" & @CRLF & _
"(,,"My","Cool",,"Array",,,)" & @CRLF & _
"("My""Cool""Array")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")