$re = '/(?(DEFINE)
(?<string>"[^"]+")
)
\(
(?&string)?
(?:,(?&string)?)*
\)/mx';
$str = '("My","Cool","Array")
("My","Cool","Array",)
(,,"My","Cool",,"Array",,,)
("My""Cool""Array")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);