import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<string>\"[^\"]+\")\n"
+ ")\n\n"
+ "\\(\n"
+ " (?&string)?\n"
+ " (?:,(?&string)?)*\n"
+ "\\)";
final String string = "(\"My\",\"Cool\",\"Array\")\n"
+ "(\"My\",\"Cool\",\"Array\",)\n"
+ "(,,\"My\",\"Cool\",,\"Array\",,,)\n"
+ "(\"My\"\"Cool\"\"Array\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}