using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<string>""[^""]+"")
)
\(
(?&string)?
(?:,(?&string)?)*
\)";
string input = @"(""My"",""Cool"",""Array"")
(""My"",""Cool"",""Array"",)
(,,""My"",""Cool"",,""Array"",,,)
(""My""Cool""Array"")";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}