re = /(?(DEFINE)
(?<string>"[^"]+")
)
\(
(?&string)?
(?:,(?&string)?)*
\)/mx
str = '("My","Cool","Array")
("My","Cool","Array",)
(,,"My","Cool",,"Array",,,)
("My""Cool""Array")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end