# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s\S]*?(\[[\d.]+])[\s\S]*/\1/;t' <<< "[Unreleased]
- bla bla bla
## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
I want to extract only the version numbers so I am left with:
[0.3.0]
- bla bla bla
[0.2.4]
- bla bla bla
[0.2.3]
- bla bla bla
"