using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]*?(\[[\d.]+])[\s\S]*";
string substitution = @"\1";
string input = @"[Unreleased]
- bla bla bla
## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
I want to extract only the version numbers so I am left with:
[0.3.0]
- bla bla bla
[0.2.4]
- bla bla bla
[0.2.3]
- bla bla bla
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}