use strict;
my $str = '[Unreleased]
- bla bla bla
## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
I want to extract only the version numbers so I am left with:
[0.3.0]
- bla bla bla
[0.2.4]
- bla bla bla
[0.2.3]
- bla bla bla
';
my $regex = qr/[\s\S]*?(\[[\d.]+])[\s\S]*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";