import Foundation
let pattern = #"[\s\S]*?(\[[\d.]+])[\s\S]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
[Unreleased]
- bla bla bla
## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
I want to extract only the version numbers so I am left with:
[0.3.0]
- bla bla bla
[0.2.4]
- bla bla bla
[0.2.3]
- bla bla bla
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}