package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s\S]*?(\[[\d.]+])[\s\S]*`)
var str = []byte(`[Unreleased]
- bla bla bla
## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
I want to extract only the version numbers so I am left with:
[0.3.0]
- bla bla bla
[0.2.4]
- bla bla bla
[0.2.3]
- bla bla bla
`)
var substitution = []byte("\1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}