#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\s\S]*?(\[[\d.]+])[\s\S]*"
Local $sString = "[Unreleased]" & @CRLF & _
"- bla bla bla" & @CRLF & _
"" & @CRLF & _
"## [0.3.0] - 2016-12-13" & @CRLF & _
"- FIX This is an example fix" & @CRLF & _
"- FEATURE An example feature" & @CRLF & _
"" & @CRLF & _
"I want to extract only the version numbers so I am left with:" & @CRLF & _
"" & @CRLF & _
"[0.3.0]" & @CRLF & _
"- bla bla bla" & @CRLF & _
"" & @CRLF & _
"[0.2.4]" & @CRLF & _
"- bla bla bla" & @CRLF & _
"" & @CRLF & _
"[0.2.3]" & @CRLF & _
"- bla bla bla" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)