#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[jsfiddle]((?:https?:)?\/\/jsfiddle\.net\/\w+\/embedded\/(?:[\w,]+)?\/?(?:dark)?(?:(?:\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\w+){0,4})\[\/jsfiddle\]"
Local $sString = "[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")