use strict;
my $str = '[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]';
my $regex = qr/\[jsfiddle]((?:https?:)?\/\/jsfiddle\.net\/\w+\/embedded\/(?:[\w,]+)?\/?(?:dark)?(?:(?:\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\w+){0,4})\[\/jsfiddle\]/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}