const regex = /\[jsfiddle]((?:https?:)?\/\/jsfiddle\.net\/\w+\/embedded\/(?:[\w,]+)?\/?(?:dark)?(?:(?:\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\w+){0,4})\[\/jsfiddle\]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[jsfiddle]((?:https?:)?\\\/\\\/jsfiddle\\.net\\\/\\w+\\\/embedded\\\/(?:[\\w,]+)?\\\/?(?:dark)?(?:(?:\\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\\w+){0,4})\\[\\\/jsfiddle\\]', 'i')
const str = `[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}