import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[jsfiddle]((?:https?:)?\\/\\/jsfiddle\\.net\\/\\w+\\/embedded\\/(?:[\\w,]+)?\\/?(?:dark)?(?:(?:\\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\\w+){0,4})\\[\\/jsfiddle\\]";
final String string = "[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}