re = /\[jsfiddle]((?:https?:)?\/\/jsfiddle\.net\/\w+\/embedded\/(?:[\w,]+)?\/?(?:dark)?(?:(?:\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\w+){0,4})\[\/jsfiddle\]/i
str = '[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end