import re
regex = re.compile(r"\[jsfiddle]((?:https?:)?\/\/jsfiddle\.net\/\w+\/embedded\/(?:[\w,]+)?\/?(?:dark)?(?:(?:\?|&)(?:fontColor|accentcolor|menucolor|bodycolor)=#?\w+){0,4})\[\/jsfiddle\]", flags=re.IGNORECASE)
test_str = "[jsfiddle]//jsfiddle.net/t903w5j8/embedded/result/dark?fontcolor=sdf&accentColor=sdf&menuColor=sdf&bodyColor=sf[/jsfiddle]"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")